Page 1 of 1

Compatability

Posted: 07 Mar 2010, 07:45
by Colligan
Simple question, I think. 64-bit compatibility? :?

Re: Compatability

Posted: 11 Mar 2010, 23:30
by Metalogic
Hi Colligan,
Yes, Finance Explorer will run on all versions of Windows from Windows 98 and up on both 32-bit and 64-bit.