Comma problem

Ask questions and get help from your fellow Metalogic Finance Explorer users.
nicolleen
Posts: 55
Joined: 13 Apr 2011, 01:16

Comma problem

Postby nicolleen » 19 Apr 2013, 01:58

Dear Metalogic,

it's me again.

I haven't been using Finance Explorer for a while now, second kid and no time.
Now I've downloaded all the new ofc/ofx files from my bank to parse them into FE. The outcome is, that I have an amazing 129,000.00 Euros in my current account! I've tried to figure out, what the problem might be, and I think I have found the culprit. On my new laptop I have the German format and the comma is a ",", and on my desktop computer, which I have been using so far, the comma is a "." Now I've got several months imported with the sums two digits off and all the sums are wrong now.

What is the best way of solving this? Can I just delete a few months import and import them again in a different format? How do I delete the imports separately?

thanks for your help,

niki

Metalogic
Site Admin
Posts: 187
Joined: 20 Feb 2010, 02:37

Re: Comma problem

Postby Metalogic » 23 Apr 2013, 23:58

Hi niki,
Sorry for the delayed reply.

First of all, congratulations on a second kid (you will need budgeting more than ever ;))

When loading a file, the import should always use a "." as the decimal separator as that is the OFX standard. It shouldn't matter whether your computer uses "." or ",". I will fix the issue and upload a new release in the coming days.

Just to double-check, would you be able to open your ofx file in Notepad and copy/paste here a sample TRNAMT tag? It will look something like this:
<TRNAMT>-123.45

I just want to confirm that your bank is exporting the tag correctly with a "." regardless of the German formatting.

As for deleting the transactions, I'm afraid there's no feature to delete an entire download at once. There is a plan to automatically make a backup of the MLFE data whenever you run it so that you have something to go back to in cases such at this. But that feature is not ready yet.
Enjoy our software? Then please submit a review.

nicolleen
Posts: 55
Joined: 13 Apr 2011, 01:16

Re: Comma problem

Postby nicolleen » 06 May 2013, 14:37

Hi, thanks for the nice reply, sorry, we've been on holidays for a week.

I will work on the issues and come back with questions in case they arise. I will try to find a backup version to eliminate the wrong imported data.

best regards,

nicolleen

nicolleen
Posts: 55
Joined: 13 Apr 2011, 01:16

Re: Comma problem

Postby nicolleen » 14 May 2013, 12:09

Hi,

sorry, for the late reply.

I have downloaded the newest version from PortableApps.com and have started from scratch.
I have downloaded the ofc-Files as usual and converted them with MT2OFX as before. I have looked at those tags you mention (TRNAMT) and the amounts look ok. Eg. 50 Euros come up as 50.00

Nevertheless, in Finance Explorer the same 50.00 Euros come up as 5,000.00 Euros. What do I do wrong if it has nothing to do with the local comma settings? Is there anything in Finance Explorer to choose which comma to use? I have tried two things, my old Finance Explorer version from my old computer, where everthing was fine, and the files exported to my old computer. I copied everything to my laptop and imported the ofx files. Problem persists. Any ideas?

lg
niki

Metalogic
Site Admin
Posts: 187
Joined: 20 Feb 2010, 02:37

Re: Comma problem

Postby Metalogic » 14 May 2013, 17:13

Hi niki,
I released a new version of Finance Explorer that should solve your issue. I see that you are using the portable version. You can grab the latest from here:
http://www.metalogicsw.com/download/financeexplorer/FinanceExplorerPortable_5.6.1_English.paf.exe

Please try that and confirm whether it solves your issue.

Thanks.
Enjoy our software? Then please submit a review.

nicolleen
Posts: 55
Joined: 13 Apr 2011, 01:16

Re: Comma problem

Postby nicolleen » 18 May 2013, 04:25

Dear Metalogics,

you are great!! Thank you very much, now it is working! I also tried it on the other computer, and it seems to detect the local comma settings now.

Thank you for your fast and helpful efforts!

best regards,
niki

Metalogic
Site Admin
Posts: 187
Joined: 20 Feb 2010, 02:37

Re: Comma problem

Postby Metalogic » 19 May 2013, 21:16

Excellent! Glad that it solved your issue.

All the best,
Metalogic
Enjoy our software? Then please submit a review.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 1 guest